Problem with glue on the jewellery

Home Forums Glass Fusing General Fusing Discussion Problem with glue on the jewellery

  • This topic has 4 replies, 3 voices, and was last updated 8 years ago by Viau.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #10000
    Viau
    Participant

    I used glue 6000 and heat activated glue.After a couple days,the bails or any metal  will fall off.I tried two different kind of epoxy and  I had the same problem.Do you know a liable glue that I can use or a process that I might forgot.Viau

    #13019
    Chris_Clark
    Participant

    I have used E6000 for several years, this new tube seems to be letting go of my earrings….. I have tried several things, cleaning the glass and silver, scratchig the glass on the glue side, and also making marks in the silver backing…. nothing seems to work at this point.

    Another glass worker at the market I sell at says he likes another glue from Delphi called…. Triolyse… http://www.delphiglass.com/mosaic-supplies/glues-chemicals/triolyse-adhesive What do you think of this?

    #13020
    Viau
    Participant

    Thanks, I will try it to see if it works for me.

    #13021
    bookie13
    Participant

    I have a tutorial on my web site (see below) about how to use E-6000 and get excellent results. There are several key steps, but it is very easy to do. I have heard some people tout heating in a toaster oven, but I question that in the long term

    Barry Kaiser

    Web Site    http://www.kaiserglass.com

    Glass Classes:   http://www.Kaiserglass.com/classes.html

    Tutorials      http://www.kaiserglass.com/tutorials.html

    #13022
    Viau
    Participant

    Thanks for you tutorial.Was very helpful.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

People Who Like Thisx

Loading...